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I N T R O D U C T I O N

Welcome to the CertBOIS module: Spreadsheet II - More Number Crunching.

As with all the CertBOIS course material, the student manuals follow a common format 
and design:

Chapters
Each module is divided into several chapters. If you are not sure if you’re ready for a 
chapter, look at the prerequisites that appear at the beginning of each chapter. They will 
tell you what you should know before you start the chapter.

Tutorials
Each chapter contains several tutorials on related topics. Each tutorial explains a new skill 
or topic and contains a step-by-step exercise to give you hands-on-experience.

Chapter Reviews
A review is included at the end of each chapter to help you absorb and retain all that you 
have learned. This review contains a brief recap of everything covered in the chapter’s 
tutorials, review questions to assess how much you’ve learned and which tutorials you 
might want to look at again.

Operating System and Graphics Used in This Module
This module has been witten based on a computer running the  Windows XP operating 
system.  There are four current versions of Windows operating system: Windows ME, 
Windows 2000, Windows NT and Windows XP (itself available in both Home and 
Professional versions).

Similarly, Microsoft Excel, used within this module, is currently available in three versions: 
Excel 2000, Excel XP (sometimes referred to as Excel 2002) and  Excel 2003.

Whilst most of the commands used in this module are common to all versions, some will 
vary, as will the graphics displayed on the screen.  Where there is significant difference in 
either what is displayed, or in functuality, this will be indicated and an explanation given.
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How to Use the Tutorials
Wherever possible every topic is presented on two facing pages, so that you can 
concentrate on the tutorial without having to worry about turning the page. Since this is a 
hands-on course, each tutorial contains an exercise with step-by-step instructions for you 
to follow.

To make learning easier, every exercise follows certain conventions:
Anything you’re supposed to click, drag, or press appears like this.
Anything you’re supposed to type appears like this.
This module never assumes you know where (or what) something is. The first time 
you’re told to click something, a picture of what you’re supposed to click appears 
either in the margin next to the step or in the illustrations.
When you see a keyboard instruction like “press <Ctrl> + <B>,” you should press 
and hold the first key (<Ctrl> in this example) while you press the second key (<B> 
in this example). Then, after you’ve pressed both keys, you can release them.
There is usually more than one way to do something in Excel. The exercise explains 
the most common method, while the alternate methods appear in the margin. Use 
whatever approach feels most comfortable for you.
Important terms appear in italics the first time they’re presented.
Whenever something is especially difficult or can easily go wrong, you’ll see a NOTE: 
immediately after the step, warning you of pitfalls that you could encounter if you’re 
not careful.
Quick Reference boxes appear at the end of some tutorials. You can use them to 
review the skills you’ve learned in the tutorial and as a handy reference—when you 
need to know how to do something quickly and don’t need to go through the sample 
exercises.

 Download Module Files
To help you with the tutorials in this module, we have developed a set of files for you.  
You will need to download these from our Web site.  Using an Internet browser, enter 
http://www.moustraining.uk.com/resources or select Student Resource Centre, then Course 
Downloads from the main menu.  Select the Phase 2 modules link and locate MTC112 in 
the list of modules.  You will be able to download the MTC112.exe file by clicking on the 
MTC112 link.

You will be asked if you wish to Open or Save the file; select Save, and choose the folder 
to save the file into.  Once downloaded, browse to that folder, and double-click the file.  It 
will automatically save the files to your c:\certbois\MTC112 folder.

•
•
•

•

•

•
•

•
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P E R S O N A L 

D E V E L O P M E N T 

P L A N N I N G

How can PDP help me?
PDP helps you:

become a more effective, independent 
and confident learner; 
value you own capabilities through 
greater self-awareness;
understand more clearly how you 
learn and how you can improve your 
performance; 
improve your reflective thinking 
skills which can strengthen academic 
performance; 
articulate your skills, personal qualities 
and competences to employers; 
improve your employability;
develop greater self-awareness: what 
you are like, what your strengths and 
weaknesses are, what you want to 
achieve;
make appropriate choices to meet your 
aspirations.

•

•

•

•

•

•
•

•

To help you to engage in the PDP process 
there are reflective elements built into each 
of your modules.  By completing these and 
considering other aspects of your life where 
you are learning and developing professional 
and transferable skills, you will be able 
to build a portfolio of evidence of your 
achievements to which you yoiurself can 
refer and which you can present to others

Module: MTC112 – SpreadsheetsII 
- More number crunching
This module covers skills in:

Functions and Formulas
Lists
Macros
Working with Other Programs

Prior to starting this module, take a few 
minutes to think about what you want to gain 
from completing it.  Jot down some notes, 
overleaf, about your success criteria.  In what 
way do you think this achievement will take 
you forward in life?  

•
•
•
•

 
 How involved are you in your 

own personal development 
planning?

What is PDP?
 Personal Development Planning (PDP) is a process of reviewing your academic and non-
academic achievements, reflecting on your progress and identifying some targets for your 
future development.
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Chapter Objectives:

Create a formula with several operators and cell ranges

Use the Insert Function feature to enter and edit formulas

Create and use range names

Select nonadjacent cell ranges

Use the AutoCalculate feature

Create a conditional formula with the IF function

Use the PMT function

Display and print formulas in a worksheet

Identify and fix formula errors

Chapter Task: Create payroll and mortgage worksheets

Formulas are the heart and soul of a spreadsheet. Without formulas, Excel would be 
nothing more than a grid you could use to enter numbers and text. As you will see in 
this chapter, formulas can do a lot more than just adding, subtracting, multiplying, and 
dividing. Excel has hundreds of different formulas you can use to create complex statistical, 
financial and scientific calculations. The most expensive calculator in the world couldn’t 
come close to matching all the functions Excel has.

This chapter is a little different from the others in this module: it’s broken into two different 
parts. In the first part of this chapter, you will become an expert at creating formulas and 
using different types of functions. The second part of this chapter consist of reference tables 
of the most commonly used functions, organised by category.

•

•

•

•

•

•

•

•

•

Prerequisites

How to use 
menus, toolbars, 
dialog boxes 
and shortcut 
keystrokes

How to select 
cell ranges

How to enter 
values, labels 
and formulas 
into a cell

How to 
reference cells

C H A P T E R  1 : 

M O R E  F U N C T I O N S  & 

F O R M U L A S
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Tutorial 1-1: Formulas with Several 
Operators and Cell Ranges
We’ll start this chapter by creating some more complicated  formulas. First let’s review: 
Formulas can contain several values, such as 81 and 3.5; cell references, such as B5 and 
C1:D11; operators, such as * (multiplication) + (addition); and functions, such as  SUM 
and  AVERAGE. When you combine several operations and functions into a single formula, 
Excel performs the operations in the order shown in Table 1-1: Order in Which Excel 
Performs Operations in Formulas. 

When a formula contains several operators with the same precedence, Excel calculates the 
formula from left to right. You can change the order Excel calculates a formula by enclosing 
the part of the formula you want Excel to calculate first in parentheses.

You’ll get some practice creating formulas with several references and operators in this 
tutorial by creating formulas to compute employee pension contributions and net pay. 

1. Start Microsoft Excel. Open the workbook Tutorial 6A and save it as Time Sheet.
This time card calculates the employees weekly payroll for the Duluth North Shore 
Travel office. All the information and almost all of the formulas are already here; you 
just need to add a few more formulas to complete the timecard workbook. First, 
you need to create a formula to calculate how much to deposit to each employee’s 
pension account. North Shore Travel matches the employee’s pension contribution, so 
this formula will be a little trickier than what you’re used to.

2. Click cell B16 and type =.
Typing an equal sign tells Excel that you want to enter a formula.

3. Click cell B14, type * and click cell B15 (or you can type B14*B15). Don’t press 
<Enter> after entering the formula!
This part of the formula multiplies gross pay (in cell B14) with the percentage the 
employees want to deduct for their pension contribution (in cell B15.) You’re not 
finished with the formula yet—remember that North Shore Travel matches any 
pension contributions made by their employees.

4. Type *2 and press <Enter>.
Excel calculates the total pension amount, £50. Copy the formula you have just 
created to the rest of the row.

5. Copy the formula in cell B16 to the cell range C16:H16 by clicking the bottom 
right corner of cell B16 and dragging across the other cells in the row.
The worksheet needs one more formula: one to calculate the net pay.

6. Click cell B19, type = , click cell B14, and type – (minus sign).
Here’s where the formula gets tricky. You can’t directly subtract the pension amount 
from cell B16 since it includes both the employee and the company contribution. You 
will have to calculate the amount of the employee’s pension contribution and then 
subtract it from the gross pay.

7. Click cell B14 (that’s right, click cell B14 again) type * click cell B15 and press 
<Enter>.
The formula subtracts the amount of the employee deduction (5% of £500, or £25) 
from the gross pay. The formula isn’t finished yet—you have to go back and subtract 
the Income Tax and National Insurance amounts.

Remember: 
All formulas in Excel 
must begin with an 
equals sign (=).
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8. Click cell B19 and click the formula bar and type –B17-B18 at the end of the 
formula. The complete formula should now read =B14-B14*B15-B17-B18. 
Complete the formula by pressing <Enter>.
Your formula is finished and Excel calculates the net pay for the employee. 

9. Copy the formula in cell B19 to the cell range C19:H19 using the same method as 
you did in step 5.
Compare your worksheet with the one in Figure 1-1.

When you use several operators in a formula, Excel performs the operations in the 
order shown in the following table. When a formula contains operators with the same 
precedence—for example, if a formula contains both a multiplication and division 
operator—Excel calculates them from left to right. To change the order of evaluation, 
enclose the part of the formula to be calculated first in parentheses. For example, the 
formula =(10-5)+(4/2) would subtract 5 from 10, then divide 4 by 2, and then add the 
results.

Table 1-1: Order in Which Excel Performs Operations in Formulas

Operator Description

 ( ) Parentheses change the order of evaluation. For example:
=(20+5) / (10-5) would add 20 and 5 (25), subtract 10 by 5 (5) and then divide 
the results to equal 5.
But…
=20+5/10-5 would divide 5 by 10 (0.5), add the result to 20 (20.5) and then 
subtract 5 to equal 15.5.

 : Reference Operator, for specifying a range of cells.

 % Percent

 ̂ Exponentiation

* and / Multiplication and division

+ and - Addition and subtraction

=  < >  <=  >= Comparison

Figure 1-1
The completed 
worksheet

 QUICK REFERENCE
To Change the Order in which Excel Performs Operations in Formulas:

Enclose in parentheses the part of the formula to be calculated first.•

O
PE
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Tutorial 1-2: Using the Insert Function 
Feature
There are several hundred functions available in Excel. Some functions are rather easy to 
enter, such as the SUM function, while others are much more difficult. For example, the 
syntax for the DB function, which is used do depreciate an asset, is DB(cost,salvage,life,p
eriod,month). You may ask, “How am I supposed to remember that?!”. Luckily, if you use 
Excel’s Insert Function feature you don’t have to. 
The Insert Function feature helps you select, enter, and edit worksheet functions. To use 
the Insert Function feature all you have to do is click the Insert Function button on the 
formula bar.
In this tutorial, you will use the Insert Function feature to create a simple  AVERAGE 
formula.

1. If necessary open Workbook Time Sheet.  Click cell A20, click the Bold button on 
the Formatting toolbar, type Average Net Pay and press <Tab>.
In cell B20 you will use the Insert Function button to help you create a formula that 
calculates the Average Net Pay.

2. Click the Insert  Function button on the formula bar.
The Insert Function dialog box appears, as shown in Figure 1-2. Simply type a brief 
description of what you want a function to do, then click Go.  Excel will display a list 
of functions likely to fit your needs.

3. In the Search for a function box type average and click Go.
Excel displays a list of functions that are somehow related to the word ‘average’.

4. Select AVERAGE from the Function list.
Notice the bottom of the Insert Function dialog box displays a description and the 
syntax of the selected function.

5. Click OK.
The Insert Function dialog box closes, and the Function Arguments dialog box appears, 
as shown in Figure 1-3. The AVERAGE function is actually a very simple function—the 
only arguments (variables or values of a formula) it requires are the numbers you that 
you want to average.

Figure 1-2
The Insert Functions 
dialog box

Bold button

Insert Function 
button

Figure 1-3
The Function 
Arguments dialog 
box
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6. Select the cell range B19:H19.
This range contains the Net Pay for all the employees.
NOTE:  If the Function Arguments dialog box is in the way when you want to select 
a cell or cell range, you can click the Collapse Dialog Box button if any text box to 
collapse the Function Arguments dialog box and select the cell or cell range.

7. Press <Enter>.
The Function palette completes the formula for you and closes. Cell B20 calculates 
and displays the average Net Pay amount.

8. Save your work.

The Insertion Function dialog box organises formulas by categories. Table 1-2: Function 
Categories lists and describes the different types of function categories that are available. 

Table 1-2:  Function Categories

Category Description

Most Recently Used Lists the functions you’ve used most recently.

All Lists every function available in Excel.

Financial Lists financial functions to calculate interest, payments, loans, 
etc.

Date & Time Lists functions to calculate date and times values.

Math & Trig Lists maths and trigonometry functions, such as SUM, COS, and 
TAN.

Statistical Lists statistical functions to calculate averages, standard 
deviations, etc.

Lookup & Reference Lists functions that lookup data or reference values.

Database Lists functions that lookup data or calculate values in a list or 
database.

Text Lists functions that can be used with text or labels.

Logical Lists IF…THEN functions.

Information Lists functions that return information about values and the 
worksheet itself.

User Defined Lists custom functions that you (or another user have created.

The Collapse Dialog 
Box button

 QUICK REFERENCE
To Use the Insert Function button to Enter or Edit a Formula:

Select the cell where you want to enter or edit a formula and click the Insert Function button on the 
formula bar.
Select the category of the type of function you want to use from the ‘Or select a category’ drop-down list. 

Or…
Type a brief description of the function or formula you want to create and click Go.
Select the function you want to use from the “Select a function” list and click OK.

1.

2.

•
•
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Tutorial 1-3: Creating and Using  Range 
Names
References for cells and cell ranges can sometimes be difficult to read and remember. In 
the current workbook, what does the cell range B16:H16 refer to? It’s the cell range that 
contains the total pension contributions (both the employee’s and employer’s) for each 
employee. Assigning a name to a cell or cell range makes it easier to read, remember, 
and use in formulas. So instead of totalling the pension contributions with the formula, 
=SUM(B16:H16), you could use a range name to create the more legible formula, 
=SUM(Retirement).
This tutorial will show you how to create range names and use them in your formulas. This 
tutorial also explains how to use column and row heading labels in your formulas, and how 
Excel can automatically create range names for you.

1. Using workbook Time Sheet select the cell range B16:H16.
The selected cell range contains the employer and employee contributions to each 
employee’s pension account. Here’s how to give the selected cell range a meaningful 
name, instead of referring to it as B16:H16.

2. With the cell range B16:H16 still selected, click the Name box in the formula bar, 
type Retirement and press <Enter>.
Now when you need to reference the pension amounts, you can use the Range Name 
‘Retirement’ instead of the obscure and hard-to-remember cell reference B16:H16. 

3. Click cell A21, click the Bold button on the Formatting toolbar, type Retirement 
and press <Tab>.

4. In cell B21, type =SUM(Retirement) and press <Enter>.
Excel calculates the sum of the Retirement range, B16:H16.
Once you create a Named Range you can quickly select it by picking it from the 
Name box in the Formula bar.

5. Click the Name box list arrow and select Retirement.
Excel selects the Retirement range. You don’t have to manually create names; you can 
get Excel to automatically create them for you.

6. Select the cell range A5:H11, and select Insert → Name from the menu.
Here’s a brief summary of what each of the items in the Name submenu does:

Define: Creates a name for a cell, a cell range, or constant or computed value 
that you can use to refer to the cell, range, or value. (This is the same as typing it 
directly in the Name box.) You can also delete any existing names.
Paste: Inserts the selected name into the formula bar. If the formula bar is active 
and you begin a formula by typing an equals sign (=), clicking Paste will paste 
the selected name at the insertion point. If the formula bar is not active, double-

•

•

Figure 1-4
Select a cell range 
to name

The selected cell 
range, B16:H16, is 
named Retirement.

Click the Name Box, 
type a name, and 
press <Enter> to 
name the selected 
cell or cell range.
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clicking a name in the Paste Name box pastes an equal sign (=) followed by the 
selected name into the formula bar.
Create: Creates names by using labels in a selected range.
Apply: Searches formulas in the selected cells and replaces references with names 
defined for them, if they exist.
Label: Creates names for formulas by using text labels from the rows or columns 
of a selected range.

7. Select Create from the Name menu.
The Create Names dialog box appears, as shown in Figure 1-5. The Create Names will 
automatically create range names based on the current selection.

8. Verify that the Top row and Left column check boxes are checked and click OK.
The Create Names dialog box closes, and Excel automatically creates names for the 
selected cell range. You can verify that Excel created the correct names by clicking the 
Name box arrow.

9. Click the Name Box list arrow.
The column heading names should appear in the Name Box list.

10. Click anywhere in the worksheet window to close the Name Box list.
You can also use column and row labels in the worksheet to refer to data in 
formulas—without having to create any names at all!

11. Click cell A22, click the Bold button on the Formatting toolbar, type Max Hourly 
Rate and press <Tab>.

12. In cell B22, type =MAX(Hourly Rate) and press <Enter>.
Excel returns the maximum value in the Hourly Rate row, 18.50.

13. Save your work.

•
•

•

 QUICK REFERENCE
To Name a Cell or Cell Range:

Select the cell or cell range you want to name.
Click the Name box on the Formula bar, type the 
name, and press <Enter>.

To Automatically Create Names:
Select the cell or cell range you want to name.
Select Insert → Name → Create from the menu.
If necessary, change the check boxes in the 
Create Names dialog box.
Click OK.

1.
2.

1.
2.
3.

4.

To Change the Cell Reference of a Name:
Select the new cell or cell range you want to use 
as the reference.
Select Insert → Name → Apply from the menu.
Select the name you want to use on the selected 
reference and click OK.

To Delete Names:
Select Insert → Name → Define from the menu, 
select the name you want to delete and click 
Delete.

1.

2.
3.

•

Figure 1-5
The Create Names 
dialog box
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Tutorial 1-4: Selecting  Nonadjacent 
Ranges and Using  AutoCalculate
If you have got this far in the book you obviously know how to select and use cell ranges in 
your formulas. But, how do you select cell ranges that aren’t next to each other? That’s the 
first topic explained in this tutorial.
Also covered in this tutorial is Excel’s nifty AutoCalculate feature, used to calculate a total 
or average of a cell range without entering a formula.

1. Open the workbook Tutorial 6B and save it as Time Sheet2.

2. Click cell A24, click the  Bold button on the Formatting toolbar, type M-W-F and 
press <Tab>.
Next you want to total the hours from only the Monday, Wednesday, and Friday rows. 
You can select several nonadjacent cell ranges by holding down the <Ctrl> key when 
you select the ranges.

3. Make sure cell B24 is active and click the  AutoSum button on the Standard 
toolbar.

Excel selects the closest cells (B22 and B23) as the arguments for the SUM function. 
This is isn’t the cell range you want to use in your formula—you want to find the totals 
of the Monday, Wednesday, and Friday rows.

4. Select Monday’s cell range, B6:H6, press and hold the <Ctrl> key, select 
Wednesday’s cell range, B8:H8, and then select Friday’s cell range, B10:H10. 
Release the <Ctrl> button when you’ve finished.
The nonadjacent ranges in the Monday, Wednesday, and Friday rows are all selected, 
as indicated by the shimmering dotted line around each of the columns. Notice the 
formula bar displays the cell ranges: =SUM(B6:H6,B8:H8,B10:H10).

5. Press <Enter>.
Excel calculates the total hours for the Monday, Wednesday, and Friday rows.
On to the second topic covered in this tutorial—AutoCalculate. Sometimes you may 
want to calculate the total of several cells without actually creating a formula. Excel’s 
AutoCalculate makes this incredibly easy—simply select the cell range you want to 
total, and the calculation is displayed on the status bar.

6. Select the cell range B6:H10.
The AutoCalculate area of the status bar displays the total of the selected cell range: 
Sum=240. You can also use AutoCalculate to do other simple and quick calculations. 
To change the calculation type, right-click the AutoCalculate area of the status bar.

Figure 1-6
Selecting multiple 
nonadjacent ranges 
with the <Ctrl> key

AutoSum button

Press and 
hold the 
<Ctrl> 
key while 
you select 
the fi rst 
cell range 
then each 
additional 
cell or cell 
range.
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7. Right-click the AutoCalculate area of the Status bar.
A shortcut menu appears with a list of the AutoCalculate options:

None: Disables AutoCalculate.
Average: Calculates the average of the selected cells.
Count: Counts the number of non-empty cells.
Count Nums: Counts the number of cells that contain numbers.
Max: Returns the largest value in a range of cells.
Min: Returns the smallest value in a range of cells.
Sum: Adds all the numbers in a range of cells (the default setting).

You want AutoCalculate to display the average of any selected cells.

8. Select Average from the AutoCalculate shortcut menu.
AutoCalculate calculates the average for the selected cell range. Return AutoCorrect 
back to the default Sum setting.

9. Right-click the AutoCalculate area of the Status bar and select Sum.

10. Save your work. 

•
•
•
•
•
•
•

 QUICK REFERENCE
To Select Nonadjacent Cell Ranges:

Select the first cell range, then press and hold the <Ctrl> key while you select additional cell ranges.
To Use AutoCalculate:

Select the cell range you want to total or calculate. The Status bar will display the results.
To Change the AutoCalculate Function:

Right-click the AutoCalculate area of the Status bar and select the function you want AutoCalculate to use 
from the shortcut menu.

•

•

•

Figure 1-7
Shortcut menu list 
of AutoCalculate 
options
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Tutorial 1-5: Using the  IF Function to 
Create  Conditional Formulas
This tutorial introduces a very useful function, the IF function. The IF function is a 
conditional function or logical function because it will evaluate a condition you specify 
and return one value if the condition is true and another value if the condition is false. 
For example, you could use the IF function in an invoice to create a formula that would 
subtract a 5% discount from the invoice if the total was more than £500.00, otherwise it 
wouldn’t subtract anything.

The IF function contains three parts, or arguments, as shown in Figure 1-9. Since you can 
use the Insert Function button to help you create IF function formulas, you really don’t 
need to memorise the syntax of the IF function.

1. Using workbook Time Sheet2, click cell B17 and press <Delete> to clear the cell 
contents.
The income tax rate changes at different income levels. You have determined that 
employees who earn £500 or more in a week are subject to a 15% tax rate, while 
employees who earn less than £500 in a week are subject to a 10% tax rate. You can 
create a formula using the IF function to evaluate the employee’s earnings and then 
multiply it by the appropriate tax rate. The IF function is a little more difficult than 
other functions, so use the Insert Function tool to help you enter it.

2. Click the  Insert Function button on the Formula bar.
The Insert Function dialog box appears.

3. Select Logical in the Function category list, select IF in the Function name list, and 
click OK.
The  Function Arguments dialog box appears, as shown in Figure 1-8. You’re ready to 
start entering the IF formula.

4. Type B14>=500 in the in  Logical_test text box.
You just entered the first argument of the IF function, which evaluates a statement as 
true or false (see Figure 1-9). Here you want to evaluate if the value in B14 is equal to 
or greater than £500.
NOTE:  Remember, you can also create cell references by clicking the cell or cell 
range you want to reference. Click the Collapse Dialog button to collapse the function 
palette and select the cell range if the Function Arguments dialog box is in the way.
The next step is entering the true argument of the IF function. 

Figure 1-8
Creating a 
conditional formula 
using the IF function 
and the Function 
Arguments dialog 
box

Insert Function 
button

Collapse Dialog Box 
button
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5. Select the  Value_if_true text box by clicking it or pressing the <Tab> key, and 
type B14*.15.
If the values in B14 is equal to or greater than 500 the IF function will multiply the 
value in cell B14 by 0.15. Move on to the next step to complete the IF function by 
entering the Value if false argument—what the function should do if the value is not 
equal to or greater than £500.

6. Move to the  Value_if_false text box by clicking it or pressing the <Tab> key, and 
type B14*.1.
If the value in B14 is less than £500, the IF function will multiply the value in cell B14 
by 0.10. Compare your screen with the one shown in Figure 1-9.

7. Click OK to complete the formula.
The Function Arguments dialog box closes. The IF function in B17 multiplies the Gross 
Pay by 15%, since it is equal to or greater than £500.

8. Copy the formula in cell B17 to the remaining cells in row 17.
After copying the IF formula, notice that those columns with Gross Pay less than £500 
are multiplied by 10% instead of 15%.

9. Save your work and close the current workbook.

The IF function is one of the more difficult functions, but it’s also very powerful and is well 
worth the effort of learning how to use it.

 QUICK REFERENCE
To Use the IF Function in a Formula:

Write the formula using the syntax =IF(logical_test,value_if_true,value_if_false).
Or…

Click the Insert Function button on the Formula bar to open the Insert Formula dialog box.
Select Logical in the Function category list, select IF in the Function name list, and click OK.
Enter the required arguments for the IF function.

•

1.
2.
3.

Logical Test:
Value or expression 
that can be 
evaluated to be 
True or False

Value if True:
Value that is 
returned if 
Logical Test is 
True

=IF(B14>=500,B14*.15,B14*.1)
Function

Value if False:
Value that is 
returned if 
Logical Test is 
False

Figure 1-9
The syntax for the IF 
function
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Tutorial 1-6: Using the  PMT Function
The PMT function is a very valuable function if you work with property, investments, or 
loans. The PMT function calculates the payment for a loan based on periodic payments 
and a constant interest rate. For example, say you want to take out a  £10,000 car loan 
at 8% interest and will pay the loan off in four years. You can use the PMT function to 
calculate that the monthly payments for such a loan would be £244.13.You can also use 
the PMT function to determine payments to annuities or investments. For example, if you 
want to save £50,000 in 20 years by saving the same amount each month, you can use 
PMT to determine how much you must save.

1. Open the workbook named Tutorial 6C and save it as Mortgage Table.  
All of the information you need to find the monthly payments has already been 
entered. All you have to do is use the PMT function to calculate the monthly payment. 
The PMT function is a little complicated, so use the Insert Function feature to help you 
enter it.

2. Click cell D4 and click the  Insert Function button on the Formula bar.

3. Select Financial from the Or select a category list, scroll down the Select a 
Function list, select PMT, and then click OK.

The  Function Arguments dialog box appears, as shown in Figure 1-10. You’re ready 
to start entering the PMT formula to calculate the monthly mortgage payments. Look 
at Figure 1-10: the first argument of the PMT function is the interest rate. Since the 
Function Arguments dialog box is in the way, you’ll have to click the Collapse Dialog 
Box button to see and reference the cells on the worksheet.

4. Click the Rate  Collapse Dialog Box button, click cell C4, and press <Enter>.
Because you want to calculate monthly payments instead of annual payments, you 
will need to divide the annual interest rates by 12.

5. Type /12 to divide the annual interest rate.
C4/12 should appear in the Rate text box. The next argument in the PMT function is 
the Nper—the total number of payments for the loan.

6. Click the Nper box and type B4*12.
Again, you want to calculate monthly payments so you need to multiply the total 
number of years by 12. The last step in the PMT formula is entering the Pv—the 
principal.

7. Click the Pv Collapse Dialog Box button, click cell A4, and press <Enter>.
You’ve finished entering the PMT formula so you can close the Function Arguments 
dialog box.

Figure 1-10
The Function 
Arguments dialog 
box

Insert Function 
button

Collapse Dialog Box 
button

Enter button
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8. Click OK.
The Function Arguments dialog box closes, and the monthly payment, (-£1,162.95), 
appears in cell D4. 
You might ask why is the monthly payment desplayed in red (a negative number)? 
It’s because the PMT formula shows the borrower’s point of view, and therefore the 
payments are calculated as a negative cash flow. You can easily change the formula so 
that it shows a positive number by editing the formula and placing a minus sign just 
after the equals sign.

9. Edit the formula in cell D4 by clicking the Formula bar, and adding a
-  (minus sign) immediately after the = sign, so that the formula reads
=-PMT(C4/12,B4*12,A4), then click the Enter button on the Formula bar.
The PMT formula now displays the monthly payments as a positive number. Copy the 
formula to find the monthly payments for the other loans.

10. Copy the formula you have just created to the cell range D4:D6.
The PMT formula is copied. Cell D5 displays a monthly payment of £1,208.39 and 
cell D6 displays a monthly payment of £1,048.82. Now that you have calculated the 
monthly payments for each of the three loans, you can easily calculate even more 
information, such as the total interest paid and total amount paid on each loan.

11. Click cell E4, type =, click cell D4, type *, click cell B4, type *12, so that the 
formula reads =D4*B4*12, and click the Enter button on the Formula bar.
Now that you know the total amount of all the loan payments, you can find how 
much the total interest will be.

12. Click cell F4, type =, click cell E4, type -, click cell A4 and click the Enter button 
on the Formula bar.
Wow! That interest really adds up, doesn’t it?

13. Copy the formula in cell E4 into cells E5:E6. Copy the formula in cell F4 into cells 
F5:F6. Compare your workbook with the one in Figure 1-12.

14. Try experimenting with different loan amounts, interest rates, and loan lengths for 
the different loans. Then save your work and close the Mortgage table worksheet.

 QUICK REFERENCE
To Use the IF Function in a Formula:
Write the formula using the syntax PMT(rate,nper,pv)
Or…

Click the Insert Function button on the Formula bar to open the Insert Formula dialog box.
Select Financial in the Or Select a Category list, select PMT in the Select a Function list, and click OK.
Enter the required arguments for the PMT function.

1.
2.
3.

Figure 1-11
The PMT Function

Rate:
The interest 
rate per 
period

Nper:
The number 
of payments

=PMT(C4/12,B4*12,A4)
Function Pv:

The present value 
of loan amount, or 
principal

Figure 1-14
Using the PMT 
function to calculate 
monthly loan 
payments
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Tutorial 1-7: Fixing  Formula Errors
Sometimes Excel comes across a formula that it cannot calculate. When this happens, 
it displays an error value. Error values occur because of incorrectly written formulas, 
referencing cells or data that doesn’t exist, or the fundamental laws of mathematics have 
been broken.

1. Navigate to your Practice folder and open the workbook Tutorial 6D.  
This workbook, (created by a user who is not as proficient in Excel as you are), 
contains several common errors that you are likely to encounter. Notice that cells 
B7, B8, B10, and B12 all have a string of #####s in them. Technically, this isn’t an 
error—the numerical information in the cells is just too large to be displayed in the 
current cell width. To fix the problem you simply need to widen the column.

2. Double-click the line between the B and C column headers.
Excel automatically adjusts the width of the selected column so that it can display the 
widest cell entry and the #####s disappear.
Excel 2003 includes a useful new feature that checks for errors in your formulas—
think of it as spell check for mathematics. Errors are always indicated by a green 
triangle in the upper left corner of the cell. This indicates that there is an error in the 
formula.

3. Click cell D5 to select it. 
This cell displays #DIV/0!. This error code results when Excel tries to divide a number 
by zero (which is impossible as it gives an answer of infinity). Notice that a Trace Error 
button appears next to the cell. The button offers a drop-down list of things you can 
do to correct the cell.  

4. Click the  Trace Error button list and select Show  Formula Auditing Toolbar from 
the list.
The Formula Auditing toolbar appears, as shown in Figure 1-13. The Formula Auditing 
toolbar helps you find cells that have a relationship to a formula, displays formulas 
affected by changes made to the cell, and tracks down the sources of errors. 

5. Click the Trace Error button on the Formula Auditing toolbar.
An arrow appears from the cells that caused the error to the active cell, D5. Notice 
cell B5 contains a value, while cell C5 is blank—the source of the #DIV/0! error in 
cell D5. To fix the error, you must enter a value in cell C5.

6. Click cell C5, type 1 and press <Enter>. Click the Remove All Arrows button on 
the Formula Auditing toolbar to remove the tracer arrow.
The error value in cell D5 is replaced by the correct calculation of the formula. Next, 
look at cell B12, the one that calculates the agent’s commission. The commission rate 
at North Shore travel is 5 percent, so this commission amount seems too large. You 
can investigate this value by tracing the cell precedents.

7. Click cell B12 and click the  Trace Precedents button on the Formula Auditing 
toolbar.
An arrow appears from the cell range B4:B10 to cell B12. You can now easily see the 
source of the problem: the cell range includes both the sales totals and the sum of the 
sales totals, doubling the value used to calculate commission. Fix the error.

Trace Error button

Remove All Arrows 
button

Trace Precedents 
button

Figure 1-13
The Formula 
Auditing toolbar
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8. Edit the formula in cell B12 so it reads =B10*0.05 and press <Enter>.
The formula now calculates a more reasonable commission amount, £731.70. You 
can close the Formula Auditing toolbar since you’ve finished using it.

9. Click the Formula Auditing toolbar’s close button to close it.

Table 1-3: Excel Error Values lists the error values Excel displays when it encounters an error 
and what these rather cryptic-looking error values mean.

Table 1-3:  Excel Error Values

Error Value Description

 ##### The numeric value is too wide to display within the cell. You can 
resize the column by dragging the boundary between the column 
headings.

 #VALUE! You entered a mathematical formula that references a text entry 
instead of a numerical entry.

# DIV/0! You tried to divide a number by zero. This error often occurs when 
you create a formula that refers to a blank cell as a divisor.

# NAME? You entered text in a formula that Excel doesn’t recognize. You may 
have misspelled the name or function, or typed a deleted name. 
You also may have entered text in a formula without enclosing the 
text in double quotation marks.  

# N/A This error occurs when a value is not available to a function or a 
formula. If certain cells on your worksheet contain data that is not 
yet available, enter #N/A in those cells. Formulas that refer to those 
cells will then return #N/A instead of attempting to calculate a 
value.

 #REF! The #REF! error value occurs when a cell reference is not valid. You 
probably deleted the cell range referenced to in a formula.

# NUM! The #NUM! error value occurs when you used an invalid argument 
in a worksheet function.

 #NULL! You specified an intersection of two ranges in a formula that do not 
intersect.

 Quick Reference

To Display or Hide the Formula Auditing Toolbar:
Select Tools → Formula Auditing → Show Formula Auditing Toolbar.

To Correct Formula Errors:
Refer to Table 1-3: Excel Error Values.
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Tutorial 1-8: Displaying and  Printing 
Formulas
Excel normally displays the results of formulas in the worksheet, but not the actual formula. 
You can choose to have the actual formulas displayed by Excel in the worksheet cells 
instead of their results, however, and learning how to do that is the topic of this tutorial. 
Once you display a worksheet’s formulas, you can print them for documentation purposes.

1. Select Tools → Options from the menu and click the View tab.
The View tab of the Options dialog box appears, as shown in Figure 1-14.

2. In the Window options section, check the  Formulas check box, then click OK.
The Options dialog box closes. Notice that the worksheet columns are expanded, and 
instead of displaying the results of formulas, they now display the actual formulas, 
as shown in Figure 1-15. Since the worksheet columns are so wide, you will have to 
scroll through the worksheet to see all of the formulas.

3. Scroll the worksheet horizontally, until you can see the F column.
You can also print the worksheet with the formulas displayed. For the formulas to 
be meaningful when they are printed, however, you need to tell Excel to print the 
worksheet row number and column letter headings.

4. Select File → Page Setup from the menu and click the Sheet tab.
Now specify that you want the row and column headings to be printed.

5. Check the Row and column headings check box and click OK.
Now preview your worksheet to see how it will look when printed.

Figure 1-14
The View tab of the 
Options dialog box

Figure 1-15
A worksheet with 
formulas displayed
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6. Click the Print Preview button on the Standard toolbar. Use the  pointer to 
zoom in and out of the worksheet.
The worksheet will be printed with the formulas and the row and column headings 
displayed.

7. Click Close.

8. Select Tools → Options from the menu, make sure the View tab is selected, click 
the Formulas check box to deselect it, and then click OK.
Excel displays the results of the formulas instead of the formulas themselves.

9. Close the workbook without saving it.

Print Preview 
button

 Quick Reference

To Display or Hide Worksheet Formulas:
1. Select Tools → Options from the menu and click the View tab.
2. Check or uncheck the Formulas check box.
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 Mathematical Functions
You can find any of Excel’s mathematical functions on a typical scientific calculator. If you 
still remember your algebra classes, many of these functions, such as SIN, COS, and LOG 
may be familiar to you, but don’t worry if you don’t understand all of them as some are 
quite complex. 

Obviously you aren’t expected to learn the following tables, but rather use them as points 
of reference. 

Function Syntax Description

 ABS =ABS(number) Determines the absolute value of a number. 
The absolute value of a number is the 
number without its sign (its magnitude).

 ACOS =ACOS(number) Returns the arccosine of an angle. ACOS is 
the inverse of the COS function.

 ASIN =ASIN(number) Returns the arcsine of an angle. ASIN is the 
inverse of the SIN function.

 COMBIN Calculates the number of possible 
combinations from a given number of 
items.
Example: You want to form a two-person 
team from five candidates, and you want 
to know how many possible teams can be 
formed.
COMBIN(5, 2) equals 10 teams.

 COS =COS(number) Returns the cosine of an angle (angle must 
be entered in radians).

 DEGREES =DEGREES(angle) Converts radians into degrees.

 EVEN
 ODD

=EVEN(number) Rounds a number up to the nearest even or 
odd integer.

 EXP =EXP(number) Calculates the value of the constant e 
(approximately 2.71828182845904) raised 
to the power specified by its argument.
Example: EXP(2) equals e2, or 7.389056

 FACT =FACT(number) Calculates the factorial of a number. The 
factorial of a number is the product of all 
the positive integers from one up to the 
specified number.
Example: FACT(5) equals 1*2*3*4*5 
equals 120

 LN =LN(number) Calculates the natural (base e) logarithm of 
a positive number.

 LOG =LOG(number, 
base)

Calculates the logarithm of a positive 
number using a specified base.
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Function Syntax Description

 LOG10 =LOG(number) Calculates the base 10 logarithm of a 
number.

 MOD =MOD(number, 
divisor)

Returns the remainder after number is 
divided by divisor.
Example: MOD(3, 2) equals 1, the 
remainder of dividing 3 by 2.

 PI =PI( ) Returns the value of the constant pi (π), 
accurate to 14 decimal places.

 POWER =POWER(number, 
power)

Raises a number to the specified power.

 PRODUCT =PRODUCT(numb
er1,number2...)

Multiplies all the numbers in a range of 
cells.

 RADIANS =RADIANS(angle) Converts degrees to radians.

 RAND =RAND() Generates a random number between 0 
and 1.

 RANDBETWEEN =RANDBETWEEN 
(bottom, top)

Generates a random number between the 
bottom and top arguments.

 ROUND
 ROUNDDOWN
 ROUNDUP

=ROUND(number, 
num_digits) 

Rounds a number to a specified number 
of digits. The ROUNDDOWN and 
ROUNDUP function take the same form as 
the ROUND function, and as their name 
implies, always round either up or down.

 SIGN =SIGN(number) Determines the sign of a number. Results 
in 1 if the number is positive, zero (0) if 
the number is 0, and -1 if the number is 
negative.

 SIN =SIN(number) Returns the sine of an angle (angle must be 
entered in radians).

 SQRT =SQRT(number) Returns a positive square root of a number.

 SUM =SUM(number1, 
number2…)

Adds all the numbers in a range of cells. 
You can enter the SUM function by clicking 
the AutoSum button on the Standard 
toolbar.

 TAN =TAN(number) Returns the tangent of an angle (angle must 
be entered in radians).
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 Financial Functions
Excel’s financial functions are vital if you work with investments or real estate. Financial 
functions help determine loan payment amounts, calculate the future value of investments, 
and find rates of return. 

Function Syntax Description

 FV =FV(rate, number 
of periods, payment, 
present value*, 
type*)

Calculates the future value of an investment 
based on periodic, constant payments and 
a constant interest rate.
Example: You plan to deposit £2,000 a year 
for 35 years into an IRA, and you expect a 
10% average rate of return.
FV(10%,35,-2000) equals £542,048.74

 IMPT =PMT(rate, period, 
number of periods, 
present value, future 
value*, type*)

Calculates the interest payment for over 
a specified period of time, with constant 
periodic payments and a constant interest 
rate.
Example: The following formula calculates 
the interest due in the first month of a 
three-year £8000 loan at 10 percent annual 
interest:
IPMT(0.1/12, 1, 36, 8000) equals -£66.67

 IRR =IRR(values, guess) Calculates the internal rate of return of 
investments. The investments do not have 
to be equal, but they must occur at regular 
intervals. The internal rate of return is the 
interest rate received for an investment 
consisting of payments (negative values) 
and income (positive values) that occur at 
regular periods.
Example: You want to start a business. It 
will cost £40,000 to start the business, and 
you expect to net the following income in 
the first three years: £10,000, £15,000, 
and £20,000. Enter the four values in the 
cells A1:A4 of the worksheet, making sure 
to enter the initial £40,000 investment as a 
negative value.
IRR(A1:A4) equals 5%

 NPV =NPV(rate, value1, 
value2, ...)

Calculates the net present value of an 
investment by using a discount rate and a 
series of future payments (negative values) 
and income (positive values).
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Function Syntax Description

 PMT =PMT(rate, number 
of periods, present 
value, future value*, 
type*)

Calculates the payment for a loan based on 
constant payments and a constant interest 
rate.
Example: The following formula calculates 
the monthly payment on a £20,000 loan 
with an annual interest rate of 9% that must 
be paid in 36-months.
PMT(9%/12, 36, 20000) equals (£635.99)

 PV =PV(rate, number 
of periods, payment, 
future value*, type*)

Returns the present value of an investment.
Example: An annuity that pays £600 every 
month for the next 20 years costs £50,000, 
and the money paid out will earn 7%. You 
want to determine whether this would be 
a good investment. Using the PV function, 
you find that the present value of the 
annuity is:
PV(0.07/12, 12*20, 600, , 0) equals 
(£77,389.50)

 RATE =RATE(total number 
of payments, 
payment, present 
value)

Determines the interest rate per period of 
an annuity.
Example: You want to calculate the rate of 
a four-year (48 month) £8,000 loan with 
monthly payments of £200. Using the RATE 
function you find:
RATE(48, -200, 8000) equals 0.77 percent
This is the monthly rate, because the period 
is monthly. The annual rate is 0.77%*12, 
which equals 9.24 percent.

* Optional arguments.
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 Date and Time Functions
You can use dates and time in your formulas just like any other value. For example, if cell 
A1 contained the entry 1/5/05 you could use the formula =A1+100 to calculate the date 
100 days later, which is 9/8/05.

One very important thing to know about working with date and time functions: while 
Excel can display dates and times using just about any format, it actually stores dates as 
chronological numbers called serial values. So when you think of dates as days, months, 
and years, such as 1 May, 2005, Excel thinks of dates in terms of serial numbers, such as 
36281.

NOTE:  Since the following date and time formulas often return serial number values, you 
should format any cells with date or time formulas with data and time formats that you 
can easily understand. You can also create custom number formats to display the results of 
date formulas. For example, the custom format dddd would display only the day, Monday, 
instead of the entire date, 9/8/05.  

Function Syntax Description

 DATE =DATE(year, 
month, day)

Enters a date in the cell.
Example: DATE(05,5,1) equals 1st May, 
2005.

 TODAY =TODAY( ) A special version of the DATE function. While 
the DATE function can return the value of any 
date, the TODAY function always returns the 
value of the current date.

 TIME =TIME(hour, 
minute, second)

Enters a time in the cell. Uses a 24-hour 
(military) time system.
Example: TIME(14,30,00) equals 2:30 PM.

 NOW =NOW( ) A special version of the TIME function. While 
the TIME function can return the value of any 
time, the NOW function always returns the 
value of the current time.

 WEEKDAY =WEEKDAY 
(serial_number, 
return_type)

Returns the day of the week corresponding to 
a date. The day is given as an integer, ranging 
from 1 (Sunday) to 7 (Saturday), by default. 
The serial_number argument is a date value 
(or reference to one).
Example: WEEKDAY(“14/2/06”) equals 4 
meaning Wednesday.

 YEAR =YEAR (serial_
number, return_
type)

Returns a value of the year for a specific date. 
The serial_number argument is a date value 
(or reference to one).
Example: YEAR(“15/3/2005”) equals 2005.
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Function Syntax Description

 MONTH =MONTH (serial_
number, return_
type)

Returns a value of the month for a specific 
date. The month is given as an integer, 
ranging from 1 (January) to 12 (December).
The serial_number argument is a date value 
(or reference to one).
Example: MONTH(“15/3/2005”) equals 3.

 DAY =DAY(serial_
number, return_
type)

Returns a value of the day for a specific date. 
The serial_number argument is a date value 
(or reference to one).
Example: DAY(“15/3/2005”) equals 15.

 HOUR =HOUR (serial_
number)

Returns hour value for a specific time. The 
hour is given as an integer, ranging from 
0 (12:00 A.M.) to 23 (11:00 P.M.).The 
serial_number argument is a time value 
(or reference to one). Uses a 24-hour time 
format.
Example: HOUR(“12:15:45”) equals 12.

 MINUTE =MINUTE (serial_
number)

Returns the minute value for a specific time. 
The serial_number argument is a time value 
(or reference to one). Uses a 24-hour time 
format.
Example: MINUTE(“12:15:45”) equals 15.

 SECOND =SECOND (serial_
number)

Returns a value of a second for a specific 
time. The serial_number argument is a time 
value (or reference to one). Uses a 24-hour 
time format.
Example: SECOND(“12:15:45”) equals 45.

 DAYS360 =DAYS360(start_
date,end_date)

Returns the number of days between two 
dates based on a 360-day year (twelve 
30-day months), which is used in some 
accounting calculations.
Example: DAYS360(“30/1/05”, “1/2/05”) 
equals 1
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 Statistical Functions
Excel offers a large number of functions to help you analyze statistical data. If they’re not 
enough you can also use the Analysis Toolpak which, if installed, is found under Tools → 
Data Analysis. If you cannot find it here, select Tools → Add Ins, select the Analysis Toolpak 
check box and click OK. If you are told Analysis Toolpak is not yet installed, click Yes to 
install it. 

Function Syntax Description

 AVERAGE =AVERAGE(number1, 
number2…)

Calculates the average, or arithmetic mean, of 
the numbers in the range or arguments.

 COUNT =COUNT(value1, 
value2…)

Counts the number of cells that contain 
numbers, including dates and formulas. Ignores 
all blank cells and cells that contain text or errors.

 COUNTA =COUNTA(value1, 
value2…)

Counts the number of all nonblank cells, 
regardless of what they contain.

 COUNTIF =COUNTIF(range, 
criteria, sum_range)

Counts the cells only if they meet the specified 
criteria. Similar to SUMIF.

 MAX =MAX(number1, 
number2…)

Returns the largest value in a range.

 MEDIAN =MEDIAN(number1, 
number2…)

Calculates the median of the numbers in the 
range or arguments. The median is the number 
in the middle of a set of numbers—half the 
numbers have values that are greater than the 
median, and half have values that are less.

 MIN =MIN(number1, 
number2…)

Returns the smallest value in a range.

 MODE =MODE(number1, 
number2…)

Determines which value occurs most frequently 
in a set of numbers.

 STDEV =STDEV(number1, 
number2…)

Estimates standard deviation based on a sample. 
The standard deviation is a measure of how 
widely values are dispersed from the average 
value.

 STDEVP =STDEVP(number1, 
number2…)

Estimates standard deviation based on an entire 
population.

 SUMIF =SUMIF(range,criteria, 
sum_range)

Adds the cells only if they meet the specified 
criteria.
Example: You want to total the cell range B1:B5 
only if the value in cell A1 is greater than 500.
SUMIF(A1,”>500”,B1:B5)

 VAR =VAR(number1, 
number2…)

Estimates variance based on a sample.

 VARP =VARP(number1, 
number2…)

Estimates variance based on an entire 
population.
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 Database Functions
Database functions return results based on filtered criteria. All the database functions use 
the same basic syntax =Function(database, field, criteria). The arguments include:
• Database: The cell range that makes up the list or database.
• Field: Indicates which column is used in the function. You can refer to fields by their 
column label enclosed with double quotation marks, such as “Name” or as a number that 
represents the position of the column in the list: 1 for the first column, 2 for the second, 
and so on—not the column heading numbers!
• Criteria: Is a reference to the cell or cell range that specifies the criteria for the function. 
For example, you might only want to total records from a certain region. 

Function Syntax Description

 DAVERAGE =DAVERAGE(database, 
field, criteria)

Find the average of values in a column 
in a list or database that match the 
criteria you specify.

 DCOUNT =DCOUNT(database, 
field, criteria)

Counts the number of cells that contain 
numbers from a list or database that 
match the criteria you specify.

 DGET =DGET(database, field, 
criteria)

Extracts a single record from a database 
that matches the criteria you specify.

 DMAX =DMAX(database, field, 
criteria)

Returns the largest value from a 
database that matches the criteria you 
specify.

 DMIN =DMIN(database, field, 
criteria)

Returns the smallest value from a 
database that matches the criteria you 
specify.

 DSTDEV =DSTDEV(database, 
field, criteria)

Estimates standard deviation based 
on a sample. The standard deviation 
is a measure of how widely values are 
dispersed from the average value.

 DSTDEVP =DSTDEVP(database, 
field, criteria)

Estimates standard deviation based 
on an entire population. The standard 
deviation is a measure of how widely 
values are dispersed from the average 
value.

 DSUM =DSUM(database, field, 
criteria)

Adds the values in a column in a list or 
database that match the criteria you 
specify.

 DVAR =DVAR(database, field, 
criteria)

Estimates variance based on a sample 
from selected lists or database entries.
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 Chapter One Review

Tutorial Summary

Formulas with Several Operators and Cell Ranges
If you combine several operators in a single formula, Microsoft Excel performs the 
operations in this order: ( ), :, %, ^, * and /, + and -, = <> <= >=.
Change the order of precedence by enclosing in parentheses the part of the formula 
you want to calculate first.

Using Insert Function to Enter and Edit Formulas
The Insert Function tool assists you in selecting, entering, and editing worksheet 
functions.
To Use the Insert Function tool to Enter or Edit a Formula: Select the cell where you 
want to enter or edit a formula and click the Insert Function button on the Formula 
bar.

Creating and Using Range Names
You can create a range name by selecting a cell range and then giving it a name in the 
Name box in the Formula bar.
You can refer to names in your formulas. For example, =SUM(Expenses) instead of 
=SUM(B3:B35). You can also refer to column and row headings in your formulas.
To Automatically Create Names: Select the cell or cell range you want to name and 
select Insert → Name → Create from the menu. Change the check boxes in the 
Create Names dialog box and click OK.
To Change the Cell Reference of a Name: Select the new cell or cell range you want 
to use as the reference and Select Insert → Name → Apply from the menu. Select the 
name you want to use in the selected reference and click OK.

Selecting Nonadjacent Ranges and Using AutoCalculate
Select cell ranges that aren’t next to each other by selecting the first range, and 
pressing and holding the <Ctrl> key while you select additional cells.
The Status bar displays the total (or other selected calculation) of the selected cell 
range.
To Change the AutoCalculate Function: Right-click the AutoCalculate area of the 
Status bar and select the function you want AutoCalculate to use from the shortcut 
menu.

Using the IF Function to Create Conditional Formulas
The IF function evaluates a condition you specify and returns one value if the 
condition is true and another value if the condition is false.
The syntax for the IF function is =IF(logical_test,value_if_true,value_if_false). It’s much 
easier to create IF formulas using the Insert Function tool.

Using the PMT Function
The PMT function calculates the payment for a loan based on periodic payments and 
a constant interest rate.
The syntax for the PMT function is =PMT(rate,nper,pv). It’s much easier to create PMT 
formulas using the Insert Function tool.

•

•

•

•

•

•

•

•

•

•

•

•

•

•

•
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Fixing Errors in Your Formulas
Be able to identify and correct any error values.
The Formula Auditing toolbar helps track the cause of an error. Display it by selecting 
Tools → Formula Auditing → Show Formula Auditing Toolbar.

Displaying and Printing Formulas
To Display or Hide Worksheet Formulas: Select Tools → Options from the menu 
and click the View tab and check or uncheck the Formulas check box.

Review Exercise

1. Excel always calculates formulas from left to right. (True or False?)

2. Which of the following formulas will Excel NOT be able to calculate? (Trick 
Question!)

=SUM(A1:A5)-10
=SUM(Sales)-A3
=SUM(A1:A5)/(10-10)
=SUM(A1:A5)*.5

3. Which of the following statements is NOT true?
The Insert Function button on the Formula bar helps you select, enter, and edit 
formulas.
Range names can contain up to 255 characters, including spaces.
You can create a range name by selecting a cell range and entering the range 
name in the Name box in the Formula bar.
You can refer to range names when you reference cells in your formulas.

4. Which of the following statements is NOT true?
You can select cell ranges that aren’t next to each other by selecting the first cell 
range, pressing and holding the <Ctrl> key and selecting any additional cell 
ranges.
=IF(A4 >10, 0.5, 0) is a example of a properly entered formula using the IF 
function.
If the Insert Function tool obscures the cells you want to reference in a formula 
you can click the Collapse Dialog box to temporarily shrink the Insert Function 
tool.
Excel displays the error value “######” when it doesn’t recognize the text 
you’ve entered into a formula.

5. Which is the fastest method to find the total of a cell range? 
Select a blank cell, click the AutoSum button on the Standard toolbar, select the 
cell range and click <Enter>.
Select a blank cell, type “=SUM”, select the cell range, type “)” and click 
<Enter>.
Select the cell range and the status bar will display its total.
Select the cell range, click the AutoSum button, and the Name box in the Formula 
bar will display the total.

6. What does the error #DIV/0! mean?

•
•

•

A.
B.
C.
D.

A.

B.
C.

D.

A.

B.

C.

D.

A.

B.

C.
D.
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That a number value is too wide to display within the cell.
That a formula is divided by zero or an empty cell.
That a formula is divided by the letter O.
That you won’t be receiving any stock dividends this year.

7. You are thinking about buying a £250,000 house. What function can help you 
calculate your monthly payments?

SUM.
IF.
PMT.
COUNT.

8. Which of the following statements is NOT true?
Range names can make it easier to reference cells. For example, instead of typing 
(A1:B10) you could refer to the same cell range by its name, Expenses.
You can create a range name by selecting a cell range and then entering its name 
in the Name box in the Formula bar.
You can’t use range names in a formula.
You can use column and row labels in a worksheet to refer to data in formulas.

9. Which of the following formulas would find the smallest number in the cell range 
B10 to E25?

=COUNT(B10:E25).
=MIN(B10:E25).
=FIND(B10:E25).
=SMALL(B10:E25).

 

Review Answers

1. False. If you combine several operators in a single formula, Microsoft Excel 
performs the operations in this order: ( ), :, %, ^, * and /, + and -, = <> <= 
>=.

2. C. The (10-10) portion of the formula would result in 0, causing the formula to 
divide by 0, which, if you remember your maths classes, is impossible (gives an 
infinitely large number).

3. B. Range names cannot have spaces in them.

4. D. The error value “######”means a numeric value is too wide to display 
within the cell. You can resize the column by dragging the boundary between the 
column headings.

5. C. AutoCalculate automatically displays the total of any selected cells in the status 
bar and is the fastest and easiest method to find the total of a cell range.

6. B. #DIV/0! is the division by zero error.

7. C. The PMT function calculates the payment for a loan based on periodic 
payments and a constant interest rate.

8. C. You can use range names in a formula, for example =SUM(Income).

9. B. =MIN(B10:E25) would find the smallest number

A.
B.
C.
D.

A.
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MTC112 – Spreadsheets II – More number crunching 
 
This assignment builds on an understanding of the learning covered within CertBOIS 
module MTC112. 
 
For this assignment you will need to use the data file MTC112.csv that was included 
within the module download files.  This file is a partial list of telephone calls made 
during February 2005. 
 

Using Excel, open the MTC112.csv data file, and save the workbook in Excel 
format and with a filename MTC112T1.  
1. Format the spreadsheet appropriately to make the worksheet user friendly. 

 
2. In the spreadsheet include relevant formula to work out the average duration 

and cost of all the telephone calls.  
 

3. Create a List which allows you to keep a check on the number, cost and 
average duration of calls made to different towns.  
 

4. Create a custom AutoFilter, to select all calls made to Plymouth or Exeter 
telephone numbers, sorted in ascending order.  Copy this information to a new 
worksheet – call it ‘PlymExe’ - within the same workbook. 
 

5. Using all of the data within the original worksheet you need to establish 
whether the calls made are either ‘Local’ (calls made to Plymouth) or ‘Long 
Distance’ (all others calls). Create a new column, appropriately named, and 
write a relevant formula to enable the automatic labelling of each call as either 
Local or Long Distance.  
 

6. You have been asked to supply details of costs and duration of long distance 
and local telephone calls.  In Word, create a Memo document with appropriate 
memo header etc., and embed a column chart which summarises and compares 
the total cost and duration of Local and Long Distance calls.  
 

7. Since calls to mobile and premium telephone numbers have been made from 
the office, you have decided to log all future calls as they are made.  In the 
same workbook, create a new worksheet, allowing you to enter future call 
details as they are made.  Ensure that your worksheet has the necessary data 
validation to display an alert when any call is made to a mobile or premium 
line telephone number (starting 07 or 09).   
 

8. Using the worksheet created in Task 7, create a Macro that will allow you to 
enter all new call records into the worksheet using Input boxes. 
 

9. Complete the End of Module Reflection form included within the MTC112 download 
files. 
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Your attention is drawn to the marking criteria for additional information on what to 
include in each task.  
 
Sending in your work: 
When you have completed the assignment, you will need to create two zipped files using 
WinZip or similar, to prevent e-mail systems from seeing them as ‘potentially unsafe 
attachments’.  The first should contain your Excel workbook and word document, the 
second should contain your End of Module Reflection form. 
 
Send your compressed files as e-mail attachments to bois@moustraining.uk.com 
The subject line should read: your surname, forename and MTC112-0306 
 
Task 1 – Appropriate formatting of worksheet   5 marks 
Task 2 – Formula applied      5 marks 
Task 3 – Creation of check list    10 marks 
Task 4 – Creation of AutoFilter   15 marks 
Task 5 – Formula for Automatic labelling  15 marks 
Task 6 – Memo with embedded chart   15 marks 
Task 7 – New worksheet with data validation 15 marks 
Task 8 – Macro allowing use of Input boxes  20 marks 
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